To resolve the "npm ERR! Invalid dependency type requested: alias" error, you need to ensure that your package.json file and your npm configuration are correct. This error occurs when there's an issue with how you're specifying dependencies, especially when using aliases. You can try below step to fix it:

  1. Check package.json: Open your project's package.json file and review the dependencies section.
  2. Verify Dependency Type: Check that all dependencies are specified using the correct format. Dependencies should be listed under "dependencies", devDependencies" or "peerDependencies", depending on their use.
  3. Remove Invalid Entries: If you have any entries using an unsupported dependency type such as "alias", remove or correct them.
  4. Check npm Configuration: Check your npm configuration and any custom settings that might be affecting dependency resolution.
  5. Update npm: Ensure you're using the latest version of npm. You can update npm by running:
npm install -g npm@latest

After updating npm, try installing your dependencies again. If you're still encountering the error, follow these additional steps:

  1. Clean npm Cache: Sometimes, the npm cache can become corrupted, leading to installation issues. You can clean the npm cache by running:
npm cache clean --force

Once the cache is cleaned, try installing your dependencies again:

npm install

If you're using Yarn instead of npm, you might encounter similar errors due to incompatible dependency types. Make sure your package.json and yarn configuration are correct, and consider running yarn install to resolve any dependency issues.

Solution 2:

When we encountered issues while upgrading to the latest version of npm, particularly facing the "ERR! Invalid dependency type requested: alias" error, we found a couple of solutions that might help:

  1. Firstly, we can try installing npm version 6.9.0, as previous versions didn't have alias support and should install without any issues:
npm i -g [email protected]
  1. Once npm v6.9.0 is installed, we can proceed to upgrade to the latest version of npm:
npm i -g npm@latest

If this doesn't resolve the issue, there might be conflicts with specific dependency versions. For example, if your project is requesting [email protected] but a different version (e.g., 2.2.1) was installed instead, it could cause an invalid dependency error.

In such cases, we need to ensure that dependencies like React are upgraded to the required version range (e.g., ^15.4.2 instead of fixed version 15.4.1). We can achieve this by setting a new version of the dependency:

npm install -S react@^15.4.2

However, if a dependency like react-tap-event-plugin relies on a specific webpack version (e.g., 2.2.0-rc3), we shouldn't upgrade webpack. Instead, we can call npm update --dev to ensure all registered dependencies are installed with the correct versions.

If none of these solutions work, a straightforward yet effective approach is to remove the node_modules folder and reinstall all packages from scratch:

rm -rf node_modules
npm install